OB单机服务器关机后无法启动

水军不要来我这里刷评论


问题现象:
OB单机服务器关机后无法启动,使用 obd cluster start xxx 后出现 start observer 等日志信息,在显示连接 observer 时卡住直到超时报错。期间没有任何额外日志信息,observer 日志没有新增,obshell 日志也没有新增,无从排查。

类似问题: observer重启卡死 - 社区问答- OceanBase社区-分布式数据库


如何复现:

  1. oceanbase 数据库版本 4.3.5 版本(我是这个版本,我看社区有人反馈 4.5.0 也有类似问题)
  2. obd cluster start xxx 启动数据库
  3. 不要使用 obd cluster stop xxx 关闭数据库
  4. 服务器直接重启
  5. obd cluster start xxx 即可复现

这是个高概率事件,不确保100%复现,但概率挺高。


如何修复

  1. 复现该问题后(此时超时报错,数据库没起来),使用 obd cluster stop xxx 关闭数据库。
  2. 重启服务器。
  3. obd cluster start xxx 即可正常启动。

需求:这个问题确实存在,对我来说已经排查出了间接修复方法,希望官方能排查下打个补丁。另外给其他小伙伴一些思路,避免搞不定只能删库重装。

1 个赞

我理解直接突然关机,元数据信息写入metadb失败,状态未知,所以你start会失败。等一会再看看状态,应该是能自已启来恢复正常的。我之前用过4.3.5没有遇到过这样的问题,测试环境经常突然关机了恢复后都是正常的。今天验证了4.4.2LTS没有这样的问题

可以把启动时候的obd.log和observer.log发一下 他那个不一定和你的相同 发日志看看

支持一下

是非正常关机么