oceanbase-ce-4.2.5.1-201000022024111819包升级报错问题

【 使用环境 】 测试环境
【 OB 】
【 使用版本 】4.2.5.1 24111819
【问题描述】 我在使用4.2.5.1 24111819版本的rpm包升级到4.2.5.7版本时候升级过程中ob进程无法正常启动看了一下大致ocp日志,主要就是ob进程没完全启动好,rpm包版本如下,
oceanbase-ce-4.2.5.1-201000022024111819.el7.x86_64.rpm

但是换成4.2.5.1 120918版本就能升级成功,这两种rpm包只是月份不一样,并且120918这个rpm包在ocp上也是没有非正式软件包提示
oceanbase-ce-4.2.5.1-101000092024120918.el7.x86_64.rpm

请问 24111819这个版本是不是 有潜在风险的非正式版本,这个包也是当初出来的时候在官方网站下载安装的,我现在从这个版本去升级到4.2.5.7过程中observer无法启动,并且ocp业务不认可这个版本包。4.2.5.1 120918版的包就能正常升级,ocp也能正常识别。

4 个赞

都是社区版么?当时升级的时候 有日志信息 ocp有截图么

2 个赞

感谢已经解决了

1 个赞

能具体说说 什么原因导致的么?还是操作的问题?

1 个赞

原因是当前的4.2.5.1-201000022024111819版本代码里的数据存在私有存储格式,和bp1和bp7 都不一样,导致升级到bp7后解析本地数据失败。

内部没查到这个版本的发布记录,暂时无法确认包的由来。

该版本无法直接升级到任意版本,目前只能逻辑升级,即通过oms迁移生产数据到正式发布的版本才行。

1 个赞

请教的是你们同事

1 个赞