单机集群扩容到分布式集群后observer无法启动

oceanbase4.5版本,先建立的单机集群,后面加了2台主机,扩容分布式集群后,提示创建成功,状态也是正常运行的,但是告警里提示新加入的2台服务关闭状态。


尝试重启两台服务,任务也都是正常执行完的,但是告警里就是observer进程停止。

1 个赞

查看一下集群的状态 给截图看看 还有集群下的observer的状态 也截图看看

集群状态,老师请查看


observer状态

看着信息 不正常呀 之前ocp扩容的时候 有报错么?ocp的任务 截图看看

之前没扩容过,昨天我扩容弄了2次都报错。
但是我删除集群,直接创建分布式3节点集群是正常的。
单机–>分布式扩容却报错了。

下图为ocp上扩容日志截图,请老师查看。没报错。


扩容完出现一条告警信息,就是集群存在不工作observer

你把操作时候的ocp-server.log日志发一下 把你做的任务日志下载一下 发过来

看一下 新扩容的observer的进程

ps -ef | grep -E 'ocp_agentd|ocp_mgragent|ocp_monagent|observer'

– 直连 OB 看真实状态

SELECT svr_ip, svr_port, inner_status, status,
       start_service_time, stop_time, build_version
FROM oceanbase.__all_server ORDER BY svr_ip;

我现在换成4.2.1的包部署了。我准备用这个试试扩容怎么样,但是我现在部署单机提示这个,但是我机器是有avx,这个是啥意思,4.5是可以部署的,4.2好像不行。centos7.6的系统


你现在是把环境都铲除了么?还是怎么,这个意思是缺少avx2指令集 这个版本会去校验 但是这个版本也不建议使用了 你可以安装442bp1版本

对 我铲了,我刚才看官方文档发现

4.5查的是avx,这个我有:lscpu | grep Flags | grep avx
4.2.1报错提示的是avx2,这个我没有。

那我现在装下4.4.2的,单机,然后扩容分布式试下,一会反馈给您
官网是不是没有bp1,我看all-in-one只有4.4.2 bp2这个也可以吧。算了我单独下这个bp1的包吧,利用原来4.2.1的all-in-one环境。
image

安装442bp2的就可以

我是利旧all-in-one 4.2.1的包。单独下的4.4.2bp1的ob数据库包–然后ocp上传软件。现在我把单机装好了,我现在扩容试试


4.4.2bp1版本单机扩容1-1-1分布式,扩容完没有告警,但是列表看状态还是不对
添加2个zone


日志执行成功

集群状态正常,告警列表也没告警

但是状态还是不对

直连扩容的zone1和zone2的observer服务器,报错没有obclient,你发的查询ps进程如下


zone1的observer服务器查询如下图,inner_status没有你发的这个字段,我去掉了

附件为ocp-server日志
ocp-server.log (22.0 MB)

看着没有问题呀 正常运行呀 目前还有告警么?

正常的话,这些地方不是应该有数据吗?告警是没有。但是和4.5版本扩容是一样的问题,4.5版本是有告警observer的。

obclient按说也应该有吧,提示没有这个命令,感觉扩容不成功

看着你链接不上 你部署的用户不是admin用户么?你用root应该不行吧


节点1上root是可以执行的
最重要的是,我调整zone优先级,里面只看到一个zone1,不显示zone2和zone3

我尝试重启集群,也会提示不满足多数派,说明zone2和zone3是不对的。

这个我先跳过吧,我先搞分布式的吧,这个不知道是啥情况。后面再研究单机扩容的问题

目前不确定什么原因 从ocp-server.log日志 查看信息是没有问题 有点像是metadb的数据有问题

哦 反正我直接创建分布式都是正常的。信息都能显示,我先操作吧。