烂笔头
#1
【 使用环境 】 测试环境
【 OB or 其他组件 】OMS
【 使用版本 】
【问题描述】OMS使用的nginx起不来
OMS nginx 默认使用的端口是什么? 宿主机80端口没有进程
10 个赞
淇铭
#3
自己看一下nginx日志信息 看看具体的报错什么?
4 个赞
烂笔头
#4
/var/log/nginx/路径下日志为null,我找不到其他错误日志
2 个赞
周雄
#5
nginx默认端口是8089,端口没有被占用吧?
看一下/home/admin/logs/oms_nginx_stderr.log、oms_nginx_stdout.log日志里有没有报错
3 个赞
烂笔头
#6
宿主机查询结果 , 这是oms nginx使用的端口吗
3 个赞
周雄
#7
这个程序是cm,是不是配置文件cm端口搞错了,麻烦贴一下配置文件看下 cat /home/admin/conf/config.yaml
密码什么的隐藏一下
3 个赞
烂笔头
#10
CM是OMS的组件吧,端口冲突的原因是OMS组件间端口争用了吗
3 个赞
周雄
#11
cat /home/ds/cm/package/config/drc-cm.properties, 看一下最后面几个端口配置cmCfg.port
nginx日志在这里面/home/admin/logs/oms_nginx_stderr.log、oms_nginx_stdout.log,里面有报错吗
3 个赞
周雄
#13
看着是端口被占用了,你查一下8088端口有进程吗,这个是cm的默认端口
2 个赞
周雄
#16
这台机器上有没有其他oms环境,这两个进程pid不一样
1 个赞
烂笔头
#18
我先停止supervisorctl stop oms_drc_cm,然后启动 supervisorctl start nginx,最后重新启动 supervisorctl start oms_drc_cm , 这样规避了端口冲突。 看能不能把一个进程占用2个端口的原因找出来吧
1 个赞
周雄
#19
这个oms怎么部署的,之前有没有改过配置文件。
之前这个进程pid不是7916吗
1 个赞
烂笔头
#20
手动kill过进程,OMS是docker安装的,没有改动过端口。端口配置文件可以查吧
1 个赞
周雄
#21
这就奇怪了,我看你配置都是正确的8088,cm怎么跑到8089端口去了。
重启cm之后怎么样,cm和nginx都正常运行吗
1 个赞